1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ChasingBottoms
4 pkgname=haskell-chasingbottoms
7 pkgdesc="For testing partial and infinite values"
8 url="https://hackage.haskell.org/package/ChasingBottoms"
11 depends=('ghc-libs' 'haskell-quickcheck' 'haskell-random' 'haskell-syb')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('601a577ff45cb5565397fcc428073b7ce2c9a9e033950adb5af67977c719f83ce4fe2be378280108406ad2b9d436bd3e8d15e4b82846ffd8b881151fbe5941ed')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 runhaskell Setup test --show-details=direct
37 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39 runhaskell Setup copy --destdir="$pkgdir"
40 install -D -m644 "LICENCE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENCE"
41 rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENCE"