archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-chell / trunk / PKGBUILD
blobad8aa9571007b2dea364bfcc23abc7c3906f3a51
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=chell
4 pkgname=haskell-chell
5 pkgver=0.5.0.1
6 pkgrel=53
7 pkgdesc="A simple and intuitive library for automated testing"
8 url="https://github.com/typeclasses/chell"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-ansi-terminal' 'haskell-options' 'haskell-patience' 'haskell-random')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('3296f55a76c5ca2b7b8fc5eeb1e69d83b8e257e8253adb053f43248ca6ac4369c5f3ed2432afb5cc36d2c5bf2fe2aed8179666bf2d9c898ca6330f9f8b5e5269')
16 build() {
17     cd $_hkgname-$pkgver
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22             -fcolor-output
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 "license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
37     rm -f "${pkgdir}/usr/share/doc/${pkgname}/license.txt"