1 # Maintainer: Jelle van der Waa <jelle@archlinux.org>
3 _hkgname=classy-prelude
4 pkgname=haskell-classy-prelude
7 pkgdesc='A typeclass-based Prelude'
9 url="https://hackage.haskell.org/package/$_hkgname"
11 depends=(ghc-libs haskell-async haskell-chunked-data haskell-dlist
12 haskell-hashable haskell-mono-traversable haskell-primitive
13 haskell-unliftio haskell-stm-chans
14 haskell-unordered-containers haskell-vector-instances
15 haskell-say haskell-mutable-containers haskell-basic-prelude
16 haskell-mono-traversable-instances)
17 checkdepends=(haskell-hspec)
19 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
20 sha512sums=('4cc39f6da6f10e38a82fa189445df3dfc9ae2383fba6c6142dcabf4ed65fa8cd7784618d44fe8f2f498dda7ef0ea004853adcde932817098d67ee3558707b62d')
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE