1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=commonmark-pandoc
4 pkgname=haskell-commonmark-pandoc
7 pkgdesc="Bridge between commonmark and pandoc AST"
8 url="https://github.com/jgm/commonmark-hs"
11 depends=('ghc-libs' 'haskell-commonmark' 'haskell-commonmark-extensions' 'haskell-pandoc-types')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('d5d91748501cdb4fcb738f89ee32135eed83ff1a41a3665f86ad36286a346b4751a355cd81d29e43a47500913b94796330df9b35201586d2610dbdb4ef4fa544')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
31 runhaskell Setup test --show-details=direct
37 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39 runhaskell Setup copy --destdir="$pkgdir"
40 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
41 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE