archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-conduit / trunk / PKGBUILD
blob721566485290137f37b177091d1515f70e916907
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=conduit
5 pkgname=haskell-conduit
6 pkgver=1.3.4.3
7 pkgrel=39
8 pkgdesc="Streaming data processing library."
9 url="https://github.com/snoyberg/conduit"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-mono-traversable' 'haskell-primitive'
13          'haskell-resourcet' 'haskell-unliftio-core' 'haskell-vector')
14 makedepends=('ghc' 'haskell-hspec' 'haskell-quickcheck' 'haskell-safe' 'haskell-silently'
15              'haskell-split' 'haskell-unliftio')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('14d4557c1018514da4ae7ae41ec8a381ae57aabd86d84e2c961dce0b784ca4fb8aec5a2757c6fe6d815ce552f25bcc462c208226ca33094e0210b06651846e59')
19 build() {
20     cd $_hkgname-$pkgver
21     
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
25     runhaskell Setup build $MAKEFLAGS
26     runhaskell Setup register --gen-script
27     runhaskell Setup unregister --gen-script
28     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33     cd $_hkgname-$pkgver
34     runhaskell Setup test --show-details=direct
37 package() {
38     cd $_hkgname-$pkgver
39     
40     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42     runhaskell Setup copy --destdir="$pkgdir"
43     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
44     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE