1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-config-ini
8 pkgdesc="A library for simple INI-based configuration files."
9 url="https://github.com/aisamanra/config-ini"
12 depends=('ghc-libs' 'haskell-unordered-containers' 'haskell-megaparsec')
13 makedepends=('ghc' 'uusi' 'haskell-ini' 'haskell-hedgehog' 'haskell-doctest' 'haskell-microlens')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('3b090084c1e851ab926259646881caf6b89353bac212741195863c570d0be68e7482d2b467c9e4ce28b138da466eee435a916913d449bf442cbd67f33614c713')
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29 # https://github.com/aisamanra/config-ini/issues/38
31 runhaskell Setup build $MAKEFLAGS
32 runhaskell Setup register --gen-script
33 runhaskell Setup unregister --gen-script
34 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
40 runhaskell Setup test --show-details=direct
46 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48 runhaskell Setup copy --destdir="$pkgdir"
49 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
50 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE