archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-config-schema / trunk / PKGBUILD
blob7b73b112a5a6cbc7bf14be6a0131eab7ede847fb
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=config-schema
4 pkgname=haskell-config-schema
5 pkgver=1.3.0.0
6 pkgrel=41
7 pkgdesc="Schema definitions for the config-value package"
8 url="https://github.com/glguy/config-schema"
9 license=("ISC")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-config-value' 'haskell-free' 'haskell-kan-extensions'
12          'haskell-semigroupoids')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('3c89c55bcf5128f62462eafa0c7bc6c441ccfd8a8d2af27c972a144d7ccaabc8')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie' 
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE