1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=configurator-pg
5 pkgname=haskell-configurator-pg
8 pkgdesc="Reduced parser for configurator-ng config files"
9 url="https://github.com/robx/configurator-pg"
12 depends=('ghc-libs' 'haskell-megaparsec' 'haskell-protolude' 'haskell-scientific')
13 makedepends=('ghc' 'uusi' 'haskell-hunit' 'haskell-test-framework' 'haskell-test-framework-hunit')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('49ad984bb227e1b7bcab9139355822c5f0b928b164f4f2525d40dfaf5ccb2afed4e207b59bd8099e70a316b23f2995a7ff491ae4a739e1a9ca206e81c6225d6c')
19 uusi -u megaparsec $_hkgname.cabal
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
29 runhaskell Setup build $MAKEFLAGS
30 runhaskell Setup register --gen-script
31 runhaskell Setup unregister --gen-script
32 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 runhaskell Setup test --show-details=direct
44 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46 runhaskell Setup copy --destdir="$pkgdir"
47 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
48 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE