archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-data-bword / trunk / PKGBUILD
blobce90ac992ef88e0e6349fbf52490bf4be2300ea6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=data-bword
4 pkgname=haskell-data-bword
5 pkgver=0.1.0.2
6 pkgrel=1
7 pkgdesc="Extra operations on binary words of fixed length"
8 url="https://github.com/mvv/data-bword"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
14 sha512sums=('9275c80477362d415cb9d25616ca2f670e27c4e54d45fa345788173d74ade4b7ad4127571b39bfb2311f910cfb52ae1a23298fd2ebf0031436c1c9da35ee0521')
16 build() {
17     cd $_hkgname-$pkgver
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 package() {
30     cd $_hkgname-$pkgver
32     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
33     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
34     runhaskell Setup copy --destdir="$pkgdir"
35     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE