archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-deriving-aeson / repos / community-x86_64 / PKGBUILD
blob6deddb35823bd226381e5a9fd9c6f446aa14015b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=deriving-aeson
4 pkgname=haskell-deriving-aeson
5 pkgver=0.2.9
6 pkgrel=19
7 pkgdesc="Type driven generic aeson instance customisation"
8 url="https://github.com/fumieval/deriving-aeson.git"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha512sums=('d5112d03e8e117001a88acfed3dde85ba7c8323fbc27169215a6656787caad20faf63563558ac6ef6b8412d2fea38530ed2dcb701e7f3d952cf8ad261b49293a')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE