1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=deriving-compat
4 pkgname=haskell-deriving-compat
7 pkgdesc="Backports of GHC deriving extensions"
8 url="https://github.com/haskell-compat/deriving-compat"
11 depends=('ghc-libs' 'haskell-th-abstraction' 'haskell-transformers-compat')
12 makedepends=('ghc' 'haskell-base-compat' 'haskell-base-orphans' 'haskell-hspec' 'haskell-quickcheck'
13 'haskell-tagged' 'haskell-void')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('6948914db6cc60eb032f58d9f79c0f8e2171fb14e78f2816806fdf202e31da6944dd19245eced5d99f866aae8fe58567e6244b8d69af84291a7082d27c768958')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 runhaskell Setup test --show-details=direct
38 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40 runhaskell Setup copy --destdir="$pkgdir"
41 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE