archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-direct-sqlite / trunk / PKGBUILD
blob8573bc6e957b566b202a42073f2bcc9bd130b865
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=direct-sqlite
4 pkgname=haskell-direct-sqlite
5 pkgver=2.3.28
6 pkgrel=2
7 pkgdesc="Low-level binding to SQLite3.  Includes UTF8 and BLOB support."
8 url="https://github.com/IreneKnapp/direct-sqlite"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'sqlite')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-base16-bytestring' 'haskell-temporary')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('6744ff6cd66482bdb788a437e8970e27ae971906e52d75b68b3e6be7d03b8a44')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie' \
24       -fsystemlib
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   # https://github.com/IreneKnapp/direct-sqlite/issues/85
36   runhaskell Setup test || echo "Tests failed"
39 package() {
40   cd $_hkgname-$pkgver
42   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44   runhaskell Setup copy --destdir="$pkgdir"
45   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE