archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-distributive / repos / community-x86_64 / PKGBUILD
blobb6d7127383700afe3ee94df2377ab7c42dd05c93
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=distributive
5 pkgname=haskell-distributive
6 pkgver=0.6.2.1
7 pkgrel=184
8 pkgdesc="Distributive functors -- Dual to Traversable"
9 url="https://github.com/ekmett/distributive/"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-base-orphans' 'haskell-tagged')
13 makedepends=('ghc')
14 checkdepends=('haskell-generic-deriving' 'haskell-hspec' 'haskell-hspec-discover')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('387c7b6e0b2f917fd68d52ffbc79b9db21e488629309bfaf0dc77450bfd37c0f7f8a29458532616b5395552f84f3727b462cb2876e5aca79101e2c752b26e0a7')
18 build() {
19     cd $_hkgname-$pkgver
21     if (( CHECKFUNC )); then
22         _opts=('--enable-tests')
23     else
24         _opts=('--disable-tests')
25     fi
26    
27     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname "${_opts[@]}" \
29         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
30             -ftagged -f-semigroups
31     runhaskell Setup build $MAKEFLAGS
32     runhaskell Setup register --gen-script
33     runhaskell Setup unregister --gen-script
34     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39     cd $_hkgname-$pkgver
40     runhaskell Setup test --show-details=direct
43 package() {
44     cd $_hkgname-$pkgver
45     
46     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48     runhaskell Setup copy --destdir="$pkgdir"
49     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
50     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE