1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Dynamic reconfiguration in Haskell"
8 url="https://github.com/willdonnelly/dyre"
11 depends=('ghc-libs' 'haskell-executable-path' 'haskell-xdg-basedir' 'haskell-io-storage')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('33e26fe3f2fa7a41e766f1d070ecce975553aa374a06ee07dcb19c15fb1402b29fbbcd346f102fec3a69dfd14ee6e6681d2f012f47f145a45fdf0dd50b61dee2')
18 # Not sure why the ln here is needed, but this makes the test suite find dyre itself...
19 sed -i 's/\$HC/$HC -dynamic/;/\$HC/i cp -r ../../../Config .' Tests/*/runTest.sh
20 sed -i 's/"-v0"/"-v0", "-dynamic"/' Config/Dyre/Compile.hs
26 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
27 --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
28 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
29 runhaskell Setup build $MAKEFLAGS
30 runhaskell Setup register --gen-script
31 runhaskell Setup unregister --gen-script
32 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 runhaskell Setup test --show-details=direct
44 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46 runhaskell Setup copy --destdir="$pkgdir"
47 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
48 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE