1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
8 pkgdesc="A cross-platform, cross-console way to handle echoing terminal input"
9 url="https://github.com/RyanGlScott/echo/"
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('25fa868be5cbbc96adb4457b0e6a2fb7060b889e0dead9acef21038fd438d1ca1ee3c57ee03d91f75271e97cfea71b1d3589f800af70e15cb8cee6a60e041477')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35 runhaskell Setup copy --destdir="$pkgdir"
36 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE