archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-enummapset / repos / community-x86_64 / PKGBUILD
blobd982debf800a4353f3a7da470de1c365fc6c41a9
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=enummapset
4 pkgname=haskell-enummapset
5 pkgver=0.7.1.0
6 pkgrel=30
7 pkgdesc="IntMap and IntSet with Enum keys/elements."
8 url="https://github.com/Mikolaj/enummapset"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-quickcheck' 'haskell-test-framework'
13              'haskell-test-framework-hunit' 'haskell-test-framework-quickcheck2')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('c938bec2cdfe57c829e7bd36a6687dec506a292810de0e3611219f9a71a00efe')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-enummapset --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie' \
25     -f-debug
27   runhaskell Setup build $MAKEFLAGS
28   runhaskell Setup register --gen-script
29   runhaskell Setup unregister --gen-script
30   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 check() {
35   cd $_hkgname-$pkgver
36   runhaskell Setup test --show-details=direct
39 package() {
40   cd $_hkgname-$pkgver
42   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44   runhaskell Setup copy --destdir="$pkgdir"
45   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE