archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-fgl-arbitrary / repos / community-x86_64 / PKGBUILD
blob2c0679fb9222bdf2583ae128007bcfb1869d513f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=fgl-arbitrary
4 pkgname=haskell-fgl-arbitrary
5 pkgver=0.2.0.6
6 pkgrel=107
7 pkgdesc="QuickCheck support for fgl"
8 url="https://github.com/haskell/fgl.git"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-quickcheck' 'haskell-fgl')
12 makedepends=('ghc' 'uusi' 'haskell-hspec')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('6cf210a2ecbda21059647008cc8d85969308b21d18690f82d5f70d92435bd3d7')
16 prepare() {
17   cd $_hkgname-$pkgver
18   uusi -u hspec $_hkgname.cabal
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie'
30   runhaskell Setup build $MAKEFLAGS
31   runhaskell Setup register --gen-script
32   runhaskell Setup unregister --gen-script
33   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38   cd $_hkgname-$pkgver
39   runhaskell Setup test --show-details=direct
42 package() {
43   cd $_hkgname-$pkgver
45   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47   runhaskell Setup copy --destdir="$pkgdir"
48   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
49   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE