1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-filtrable
7 pkgdesc="Class of filtrable containers"
8 url="https://github.com/strake/filtrable.hs"
12 makedepends=('ghc' 'uusi' 'haskell-smallcheck' 'haskell-tasty' 'haskell-tasty-smallcheck')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('e3f24967f78d352ed581054a3f8c43c328a21836e023908ecce4b3e84733ed32450b8b96bfadaca39223ec7c0f397bfca34b20da29354d9ddba642361e673681')
18 uusi -u tasty $_hkgname.cabal
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup register --gen-script
30 runhaskell Setup unregister --gen-script
31 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 runhaskell Setup test --show-details=direct
43 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45 runhaskell Setup copy --destdir="$pkgdir"
46 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE