archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-filtrable / trunk / PKGBUILD
blob5fa5da572a75ac382bcde28ec848cb39112e22e7
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=filtrable
4 pkgname=haskell-filtrable
5 pkgver=0.1.6.0
6 pkgrel=161
7 pkgdesc="Class of filtrable containers"
8 url="https://github.com/strake/filtrable.hs"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc' 'uusi' 'haskell-smallcheck' 'haskell-tasty' 'haskell-tasty-smallcheck')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('e3f24967f78d352ed581054a3f8c43c328a21836e023908ecce4b3e84733ed32450b8b96bfadaca39223ec7c0f397bfca34b20da29354d9ddba642361e673681')
16 prepare() {
17     cd $_hkgname-$pkgver
18     uusi -u tasty $_hkgname.cabal
19     gen-setup
22 build() {
23     cd $_hkgname-$pkgver    
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
42     
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE