1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-fingertree
8 pkgdesc="Generic finger-tree structure, with example instances"
9 url="https://hackage.haskell.org/package/${_hkgname}"
13 makedepends=('ghc' 'haskell-hunit' 'haskell-quickcheck' 'haskell-test-framework'
14 'haskell-test-framework-hunit' 'haskell-test-framework-quickcheck2')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('c5a580c64dfe374fe818f1388e4a8870ebfc27bd09137a58fb72afee18d73b8217afe722cbe5f0017990ab28ff630cda512ca4c3c3f28e8f24622d3d15b59325')
21 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
22 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
23 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
24 runhaskell Setup build $MAKEFLAGS
25 runhaskell Setup register --gen-script
26 runhaskell Setup unregister --gen-script
27 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 runhaskell Setup test --show-details=direct
39 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41 runhaskell Setup copy --destdir="$pkgdir"
42 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE