1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
8 pkgdesc="Monads for free"
9 url="https://github.com/ekmett/free/"
12 depends=('ghc-libs' 'haskell-comonad' 'haskell-distributive' 'haskell-indexed-traversable'
13 'haskell-profunctors' 'haskell-semigroupoids' 'haskell-th-abstraction'
14 'haskell-transformers-base')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('f4e4a1463ce97ec061fae8f36e292baa60967bda8195aa8cc20dcc7a6e386232d8650a3243e126ee12087bd990242bf1b599233fd9e23728f229d8a88f270ed3')
22 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
24 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
25 runhaskell Setup build $MAKEFLAGS
26 runhaskell Setup register --gen-script
27 runhaskell Setup unregister --gen-script
28 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37 runhaskell Setup copy --destdir="$pkgdir"
38 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
39 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE