archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-fsnotify / trunk / PKGBUILD
blob7206bb335fac06d9095690ea0b384d0bb1976c42
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=fsnotify
5 pkgname=haskell-fsnotify
6 pkgver=0.4.0.0
7 pkgrel=17
8 pkgdesc="Cross platform library for file change notification."
9 url="https://github.com/haskell-fswatch/hfsnotify"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-async' 'haskell-hinotify' 'haskell-monad-control'
13          'haskell-safe-exceptions' 'haskell-unix-compat')
14 makedepends=('ghc' 'haskell-hunit' 'haskell-hspec' 'haskell-hspec-core' 'haskell-hspec-expectations'
15              'haskell-retry' 'haskell-temporary')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('bdc3f6e5c5d1cfe45f09b7515f1a36d63dee578a0f0a5dde033db75060ff31f063aa444eb4600c545a35675f2c6bf344adb4672fbc3fd4dd3747bb33f2ea16b3')
19 build() {
20     cd $_hkgname-$pkgver
21     
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
25     runhaskell Setup build $MAKEFLAGS
26     runhaskell Setup register --gen-script
27     runhaskell Setup unregister --gen-script
28     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33     cd $_hkgname-$pkgver
34     runhaskell Setup test --show-details=direct
37 package() {
38     cd $_hkgname-$pkgver
39     
40     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42     runhaskell Setup copy --destdir="$pkgdir"
43     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
44     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE