archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-fuzzy / repos / community-x86_64 / PKGBUILD
blob61732f2a557914a843fe706d1b717ac4ba7e7f71
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=fuzzy
4 pkgname=haskell-fuzzy
5 pkgver=0.1.0.1
6 pkgrel=124
7 pkgdesc="Filters a list based on a fuzzy string search."
8 url="https://github.com/joom/fuzzy"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-monoid-subclasses')
12 makedepends=('ghc' 'haskell-hunit')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha512sums=('677f03be681c2943e6e5dd0badbc2b35fc78e2805fed999b53538b2fe0d5623fbc9b91218576f0bbe414e9cd5d03d7230698e966df4b258469630fba437c20e2')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 check() {
33   cd $_hkgname-$pkgver
34   runhaskell Setup test --show-details=direct
37 package() {
38   cd $_hkgname-$pkgver
40   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
41   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
42   runhaskell Setup copy --destdir="$pkgdir"
43   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
44   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE