1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=genvalidity-property
4 pkgname=haskell-genvalidity-property
7 pkgdesc="Standard properties for functions on Validity types"
8 url="https://github.com/NorfairKing/validity"
11 depends=('ghc-libs' 'haskell-genvalidity' 'haskell-hspec' 'haskell-pretty-show' 'haskell-quickcheck'
13 makedepends=('ghc' 'uusi')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('fdb11224baad570cc91762ade0a09be924547df0cb6d3438463e17d981ac8298052051f3dc3df3ccf17386eb12e47cf68a218d4374d806f709df106018fd290c')
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup register --gen-script
30 runhaskell Setup unregister --gen-script
31 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 runhaskell Setup test --show-details=direct
43 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45 runhaskell Setup copy --destdir="$pkgdir"
46 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE