archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-getopt-generics / trunk / PKGBUILD
blobe6b136b8ecf3092ab82881854ce8bd30ba6a1c2d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=getopt-generics
4 pkgname=haskell-getopt-generics
5 pkgver=0.13.1.0
6 pkgrel=5
7 pkgdesc="Create command line interfaces with ease"
8 url="https://github.com/soenkehahn/getopt-generics"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-base-compat' 'haskell-base-orphans' 'haskell-generics-sop'
12          'haskell-tagged')
13 makedepends=('ghc' 'haskell-hspec' 'haskell-quickcheck' 'haskell-safe' 'haskell-silently')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('5f7a5cca93dec8a1dd6f3ced82d06789261fadf74a913bd61b138e91dcbb0f78725937d0446574fdc9e1c7da47ebacdca407e6c9fc22007c36609a943c9686ef')
17 build() {
18     cd $_hkgname-$pkgver    
19     
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE