archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-ghc-check / repos / community-x86_64 / PKGBUILD
blobba4fb49b8b6f3fe83a8006aff6cec39566c045c5
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ghc-check
4 pkgname=haskell-ghc-check
5 pkgver=0.5.0.8
6 pkgrel=20
7 pkgdesc="detect mismatches between compile-time and run-time versions of the ghc api"
8 url="https://hackage.haskell.org/package/ghc-check"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-ghc' 'haskell-ghc-paths' 'haskell-safe-exceptions' 'haskell-th-compat')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha512sums=('7e7d4f845c61572e94aac9f2a30a4953670f9bcdc8aa1ccf66a608932b99620d69e0fd22769582282e5fa44b904b168c4c8740fefb913a4981d4f69bddab1e72')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 package() {
33   cd $_hkgname-$pkgver
35   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37   runhaskell Setup copy --destdir="$pkgdir"
38   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
39   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE