archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-gi-gdk3x11 / repos / community-x86_64 / PKGBUILD
blobfc2659d35fcb78e2ba6765e854e3e38612ef8af6
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=gi-gdkx11
4 pkgname=haskell-gi-gdk3x11
5 pkgver=3.0.12
6 pkgrel=69
7 pkgdesc="GdkX11 bindings (GTK3)"
8 url="https://github.com/haskell-gi/haskell-gi"
9 license=("LGPL2.1")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-gi-cairo' 'haskell-gi-gdk3' 'haskell-gi-gio' 'haskell-gi-gobject'
12          'haskell-gi-xlib' 'haskell-gi' 'haskell-gi-base' 'haskell-gi-overloading' 'gtk3')
13 makedepends=('ghc' 'gobject-introspection')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('a4c14282f42ce9473db964452ca9b0a79170ac1d0dcefb0ff1923c124760a553')
17 build() {
18   cd $_hkgname-$pkgver
20   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
24     --ghc-option='-pie' 
26   runhaskell Setup build $MAKEFLAGS
27   runhaskell Setup register --gen-script
28   runhaskell Setup unregister --gen-script
29   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 check() {
34   cd $_hkgname-$pkgver
35   runhaskell Setup test --show-details=direct
38 package() {
39   cd $_hkgname-$pkgver
41   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43   runhaskell Setup copy --destdir="$pkgdir"
44   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE