1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-gi-gdkpixbuf
7 pkgdesc="GdkPixbuf bindings"
8 url="https://github.com/haskell-gi/haskell-gi"
11 depends=('ghc-libs' 'haskell-gi-gio' 'haskell-gi-glib' 'haskell-gi-gmodule' 'haskell-gi-gobject'
12 'haskell-gi' 'haskell-gi-base' 'haskell-gi-overloading' 'gdk-pixbuf2')
13 makedepends=('ghc' 'gobject-introspection')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('33b3f6abd4e20978c99dd911a1926e033e2d976e5ba3546e7fccb99269bc439a')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE