archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-gitrev / trunk / PKGBUILD
blob03c34ea4856cbd02ea2c2038405b1f79be93ed9c
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=gitrev
5 pkgname=haskell-gitrev
6 pkgver=1.3.1
7 pkgrel=31
8 pkgdesc="Compile git revision info into Haskell projects"
9 url="https://github.com/acfoltzer/gitrev"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-base-compat')
13 makedepends=('ghc')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('8639e356490fba3461f8d7030326a6913846427255524213a73ee2ac5abf708f75efed99a0d9d574a73a2db88833814d1b634e6a5ec93c4bc03052435e0ea4cd')
17 build() {
18     cd $_hkgname-$pkgver
20     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
22         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 package() {
31     cd $_hkgname-$pkgver
32     
33     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35     runhaskell Setup copy --destdir="$pkgdir"
36     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE