archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-hint / trunk / PKGBUILD
blobd7893c9d11827b4ead3ad4b051fe6a36b3806438
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hint
4 pkgname=haskell-hint
5 pkgver=0.9.0.6
6 pkgrel=18
7 pkgdesc="Runtime Haskell interpreter (GHC API wrapper)"
8 url="https://github.com/haskell-hint/hint"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-ghc' 'haskell-ghc-paths' 'haskell-random' 'haskell-temporary')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-typed-process')
13 checkdepends=('cabal-install')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('bb8ae9e6440674202c1f5dc241f2f65c3d8a69cb03ec27a5010be4959cfae51915828dc508f84423aba6c30afd5eb491f269aa4957b9e5019b0877971ea3630e')
17 prepare() {
18     cd $_hkgname-$pkgver
19     sed -i 's/"cabal" \["build"\]/"cabal" ["build", "--disable-library-vanilla", "--enable-shared"]/' unit-tests/run-unit-tests.hs
22 build() {
23     cd $_hkgname-$pkgver
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE