archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-hls-explicit-fixity-plugin / trunk / PKGBUILD
blob0d0a6a4d3e27ffe919625cbaf932359e78d9f582
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hls-explicit-fixity-plugin
4 pkgname=haskell-hls-explicit-fixity-plugin
5 pkgver=1.1.0.0
6 pkgrel=15
7 pkgdesc="Show fixity explicitly while hovering"
8 url="https://github.com/haskell/haskell-language-server.git"
9 license=("Apache")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-extra' 'haskell-ghc' 'haskell-ghcide' 'haskell-hashable'
12          'haskell-hls-plugin-api' 'haskell-lsp')
13 makedepends=('ghc' 'uusi' 'haskell-hls-test-utils')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('5c73b0ff6c77e38c8ad5b310b4eb6359f3f0c0bfa42212c63d95d9ebdc544a27')
17 prepare() {
18   cd $_hkgname-$pkgver
19   gen-setup
22 build() {
23   cd $_hkgname-$pkgver
25   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29     --ghc-option='-pie' 
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct || echo "Tests failed"
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"
49   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE