archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-hslua-module-doclayout / repos / community-x86_64 / PKGBUILD
blob9fbe25d7609643b84351f452d4b780a12e361ce3
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hslua-module-doclayout
4 pkgname=haskell-hslua-module-doclayout
5 pkgver=1.0.4
6 pkgrel=94
7 pkgdesc="Lua module wrapping Text.DocLayout."
8 url="https://github.com/hslua/hslua-module-doclayout"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-doclayout' 'haskell-hslua')
12 makedepends=('ghc' 'uusi' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-lua')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('1843532ca0721a728e38edbdefd1a5f8155b03a1612149e6d919c2cc9e735893')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' 
30   runhaskell Setup build $MAKEFLAGS
31   runhaskell Setup register --gen-script
32   runhaskell Setup unregister --gen-script
33   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38   cd $_hkgname-$pkgver
39   runhaskell Setup test --show-details=direct
42 package() {
43   cd $_hkgname-$pkgver
45   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47   runhaskell Setup copy --destdir="$pkgdir"
48   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
49   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE