archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-hslua-module-system / repos / community-x86_64 / PKGBUILD
blobe01356f1022afbd4cb5712636799a1613171b833
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=hslua-module-system
4 pkgname=haskell-hslua-module-system
5 pkgver=1.0.3
6 pkgrel=13
7 pkgdesc="Lua module wrapper around Haskell's System module"
8 url="https://github.com/hslua/hslua"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-hslua-core' 'haskell-hslua-marshalling' 'haskell-hslua-packaging'
12          'haskell-temporary')
13 makedepends=('ghc' 'uusi' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-lua')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('f8171f8d61ed90242c6b900c9bd0b468ba45b43cc9764e68442bc99bca4b946d12f1b6389775d7c217376a5f5cf3ffa2bbc26f67930a702136e3caa8341ce297')
17 prepare() {
18     cd $_hkgname-$pkgver
19     gen-setup
22 build() {
23     cd $_hkgname-$pkgver    
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
42     
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE