1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: berberman <hatsue@typed.icu>
5 pkgname=haskell-hspec-golden
8 pkgdesc="Golden tests for hspec."
9 url="https://github.com/stackbuilders/hspec-golden"
12 depends=('ghc-libs' 'haskell-hspec-core' 'haskell-optparse-applicative')
13 makedepends=('ghc' 'haskell-hspec' 'haskell-hspec-discover' 'haskell-silently')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha512sums=('b9c1d5212300848abc0e0fdc51a71cea18726574ca94f6ef337b358338c837a2a2b8ccdffc25c6eaa76422a7bc6cadea20399502f99058c4f4600b18b2d789eb')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 runhaskell Setup test --show-details=direct
41 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
42 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
43 runhaskell Setup copy --destdir="$pkgdir"
44 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
45 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE