archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-hspec-wai-json / repos / community-x86_64 / PKGBUILD
blob8e561fa6c492278f4b424b3ab1b8f760bd2633cc
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=hspec-wai-json
5 pkgname=haskell-hspec-wai-json
6 pkgver=0.11.0
7 pkgrel=383
8 pkgdesc="Testing JSON APIs with hspec-wai"
9 url="https://github.com/hspec/hspec-wai"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-aeson' 'haskell-aeson-qq' 'haskell-case-insensitive'
13          'haskell-hspec-wai')
14 makedepends=('ghc' 'uusi' 'haskell-hspec')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('db14622fd95bfb9f52a48da4e8fa345c9fdd7014aeec1cb10d75573738f8020f36d97f7085373b9b2e865a9874f377d5532e29c1f31e27f41bf5c6c89fe68546')
18 prepare() {
19     uusi -u hspec-wai $_hkgname-$pkgver/$_hkgname.cabal
22 build() {
23     cd $_hkgname-$pkgver
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE