1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
5 pkgname=haskell-http-api-data
8 pkgdesc="Converting to/from HTTP API data like URL pieces, headers and query parameters."
9 url="https://github.com/fizruk/http-api-data"
12 depends=('ghc-libs' 'haskell-attoparsec' 'haskell-attoparsec-iso8601' 'haskell-base-compat'
13 'haskell-cookie' 'haskell-hashable' 'haskell-http-types' 'haskell-tagged'
14 'haskell-time-compat' 'haskell-unordered-containers' 'haskell-uuid-types')
15 makedepends=('ghc' 'uusi' 'haskell-hspec' 'haskell-hunit' 'haskell-quickcheck'
16 'haskell-quickcheck-instances')
17 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
18 sha512sums=('04518851593fa8a081ca4ba706a7a21a693c0645968720f734df25fe884b5176a12c32f29ca9595c5de501e071b1e73bc1c45b1ae9dab5f7712ac4ac160a06db')
23 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
24 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
25 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE