1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-hw-prim
7 pkgdesc="Primitive functions and data types"
8 url="http://github.com/haskell-works/hw-prim#readme"
11 depends=('ghc-libs' 'haskell-mmap' 'haskell-unliftio-core' 'haskell-vector')
12 makedepends=('ghc' 'haskell-quickcheck' 'haskell-doctest' 'haskell-doctest-discover'
13 'haskell-hedgehog' 'haskell-hspec' 'haskell-hspec-discover' 'haskell-hw-hspec-hedgehog')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('1fa05fdc46c72ed4b28aabcee69695ce810d451bbd263fbe75f94b179e20441d')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-hw-prim --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
25 -f-bounds-checking-enabled
27 runhaskell Setup build $MAKEFLAGS
28 runhaskell Setup register --gen-script
29 runhaskell Setup unregister --gen-script
30 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
31 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 runhaskell Setup test --show-details=direct
42 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
43 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
44 runhaskell Setup copy --destdir="$pkgdir"
45 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
46 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE