archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-input-parsers / repos / community-x86_64 / PKGBUILD
blobb1afc99a44ddfccf51b4ff5165a5b9dd832c890b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=input-parsers
4 pkgname=haskell-input-parsers
5 pkgver=0.3
6 pkgrel=36
7 pkgdesc="Extension of the parsers library with more capability and efficiency"
8 url="https://github.com/blamario/input-parsers"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-attoparsec' 'haskell-monoid-subclasses' 'haskell-parsers')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('526e1f16e96090436bbfdf5d0481123da604e3bcaff08c3128552d63d897226b7b49706cfb5f87ba346bd985e9af921b273afa3fa1c4b352820e1db242de574e')
16 build() {
17     cd $_hkgname-$pkgver    
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22         -fbinary -fparsec -fattoparsec
23     runhaskell Setup build $MAKEFLAGS
24     runhaskell Setup register --gen-script
25     runhaskell Setup unregister --gen-script
26     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
30 check() {
31     cd $_hkgname-$pkgver
32     runhaskell Setup test --show-details=direct
35 package() {
36     cd $_hkgname-$pkgver
37     
38     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40     runhaskell Setup copy --destdir="$pkgdir"
41     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE