archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-lambdahack / trunk / PKGBUILD
blobca65c3366806af4a6f6fba03964dd087bb4ab839
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=LambdaHack
4 pkgname=haskell-lambdahack
5 pkgver=0.11.0.0
6 pkgrel=80
7 pkgdesc="A game engine library for tactical squad ASCII roguelike dungeon crawlers"
8 url="https://lambdahack.github.io"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-quickcheck' 'haskell-ansi-terminal' 'haskell-assert-failure'
12          'haskell-async' 'haskell-base-compat' 'haskell-enummapset' 'haskell-file-embed'
13          'haskell-hashable' 'haskell-hsini' 'haskell-keys' 'haskell-miniutter'
14          'haskell-open-browser' 'haskell-optparse-applicative' 'haskell-pretty-show'
15          'haskell-primitive' 'haskell-sdl2' 'haskell-sdl2-ttf' 'haskell-splitmix'
16          'haskell-th-lift-instances' 'haskell-unordered-containers' 'haskell-vector'
17          'haskell-vector-binary-instances' 'haskell-witch' 'haskell-zlib')
18 makedepends=('ghc' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-quickcheck')
19 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
20 sha256sums=('5526cddc753d86283c94f3072c5f5675af357a3b66c039265df55306fa62b5a5')
22 build() {
23   cd $_hkgname-$pkgver
25   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-lambdahack --enable-tests \
27     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29     --ghc-option='-pie' \
30     -f-jsaddle -frelease -fsupportnodejs -fwith_costly_optimizations -f-with_expensive_assertions
32   runhaskell Setup build $MAKEFLAGS
33   runhaskell Setup register --gen-script
34   runhaskell Setup unregister --gen-script
35   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 check() {
40   cd $_hkgname-$pkgver
41   runhaskell Setup test --show-details=direct
44 package() {
45   cd $_hkgname-$pkgver
47   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49   runhaskell Setup copy --destdir="$pkgdir"
50   install -D -m644 COPYLEFT -t "$pkgdir"/usr/share/licenses/$pkgname/
51   rm -f "$pkgdir"/usr/share/doc/$pkgname/COPYLEFT