archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-listlike / repos / community-x86_64 / PKGBUILD
blob8314aef22da21b4094f9eb4e2c64d9a36a2a6605
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=ListLike
4 pkgname=haskell-listlike
5 pkgver=4.7.8
6 pkgrel=11
7 pkgdesc="Generic support for list-like structures"
8 url="https://github.com/ddssff/listlike"
9 license=('BSD')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-dlist' 'haskell-fmlist' 'haskell-utf8-string' 'haskell-vector')
12 makedepends=('ghc' 'haskell-hunit' 'haskell-quickcheck' 'haskell-random')
13 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
14 sha512sums=('3a8235e35f287600e6011f99b32bbbdf20a3f0a84715e874e2bec6df91c7b3b6aacf34682a6816ea56033d4a31bc4eff2f16956ab91395b541da7275aefd04fd')
16 build() {
17     cd $_hkgname-$pkgver
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 check() {
30     cd $_hkgname-$pkgver
31     runhaskell Setup test --show-details=direct
34 package() {
35     cd $_hkgname-$pkgver
36     
37     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
38     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
39     runhaskell Setup copy --destdir="$pkgdir"
40     install -D -m644 "COPYRIGHT" "${pkgdir}/usr/share/licenses/${pkgname}/COPYRIGHT"
41     rm -f "${pkgdir}/usr/share/doc/${pkgname}/COPYRIGHT"