1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Lua, an embeddable scripting language"
8 url="https://hslua.org/"
11 depends=('ghc-libs' 'lua')
12 makedepends=('ghc' 'uusi' 'haskell-tasty' 'haskell-tasty-hunit')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('85546fb11ee349d3182ce11bd3046e644c2964fcfc39c797c2cd1a12e588961f')
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29 -fsystem-lua -fpkg-config
31 runhaskell Setup build $MAKEFLAGS
32 runhaskell Setup register --gen-script
33 runhaskell Setup unregister --gen-script
34 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
40 runhaskell Setup test --show-details=direct
46 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48 runhaskell Setup copy --destdir="$pkgdir"
49 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE