archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-microlens-aeson / repos / community-x86_64 / PKGBUILD
blob7686dc44e278f83ff7f39fee6cca8fc71a2f4f5c
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=microlens-aeson
4 pkgname=haskell-microlens-aeson
5 pkgver=2.5.0
6 pkgrel=32
7 pkgdesc="Law-abiding lenses for Aeson, using microlens"
8 url="https://github.com/fosskers/microlens-aeson/"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-aeson' 'haskell-attoparsec' 'haskell-hashable' 'haskell-microlens'
12          'haskell-scientific' 'haskell-vector')
13 makedepends=('ghc' 'uusi' 'haskell-tasty' 'haskell-tasty-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('b8f99796045bc5f014b1535380c680a43b2e5dd4e5543cf3b4a9683c40780a54bf4b7904a4f9cc8a6ef2c5b4caa8f74b7d116ef06011201c28b63ceac22790e4')
17 prepare() {
18     cd $_hkgname-$pkgver
19     gen-setup
22 build() {
23     cd $_hkgname-$pkgver
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28     runhaskell Setup build $MAKEFLAGS
29     runhaskell Setup register --gen-script
30     runhaskell Setup unregister --gen-script
31     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
35 check() {
36     cd $_hkgname-$pkgver
37     runhaskell Setup test --show-details=direct
40 package() {
41     cd $_hkgname-$pkgver
42     
43     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45     runhaskell Setup copy --destdir="$pkgdir"
46     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE