1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-missingh
7 pkgdesc="Large utility library"
8 url="https://github.com/haskell-hvr/missingh"
11 depends=('ghc-libs' 'haskell-hslogger' 'haskell-network' 'haskell-network-bsd' 'haskell-old-locale'
12 'haskell-old-time' 'haskell-regex-compat')
13 makedepends=('ghc' 'uusi' 'haskell-hunit')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('fc3b9684a0a14fc9a0afdd9c8ffb1ae93db122c7150b1eea1769065658092d4f')
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
32 runhaskell Setup build $MAKEFLAGS
33 runhaskell Setup register --gen-script
34 runhaskell Setup unregister --gen-script
35 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
36 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
41 runhaskell Setup test --show-details=direct
47 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
48 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
49 runhaskell Setup copy --destdir="$pkgdir"
50 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
51 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE