archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-optparse-applicative / trunk / PKGBUILD
blob51e2cbc7392cc64c50586fb40bff6f62351e6f3f
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Roger Duran <rogerduran@gmail.com>
4 _hkgname=optparse-applicative
5 pkgname=haskell-optparse-applicative
6 pkgver=0.17.0.0
7 pkgrel=41
8 pkgdesc="Utilities and combinators for parsing command line options"
9 url="https://github.com/pcapriotti/optparse-applicative"
10 license=("BSD")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-ansi-wl-pprint' 'haskell-transformers-compat')
13 makedepends=('ghc')
14 checkdepends=('haskell-quickcheck')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('986325ec8bab922aad121d2526e847ee046d9b5d5d378c0d82ba596d96d17a0221d59bf9b25d12907d3247760c5f5c657d8368a0a5fda21fbc817d81fff66dc1')
18 build() {
19     cd $_hkgname-$pkgver
21     if (( CHECKFUNC )); then
22         _opts=('--enable-tests')
23     else
24         _opts=('--disable-tests')
25     fi
27     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname "${_opts[@]}" \
29         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
30     runhaskell Setup build $MAKEFLAGS
31     runhaskell Setup register --gen-script
32     runhaskell Setup unregister --gen-script
33     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38     cd $_hkgname-$pkgver
39     runhaskell Setup test --show-details=direct
42 package() {
43     cd $_hkgname-$pkgver
44     
45     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47     runhaskell Setup copy --destdir="$pkgdir"
48     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE