1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=parser-combinators
5 pkgname=haskell-parser-combinators
8 pkgdesc="Lightweight package providing commonly useful parser combinators"
9 url="https://github.com/mrkkrp/parser-combinators"
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('f7a4581d229b788e841d844003e058a6c63827c5cadeb6fe8f1b94e2a920b11d3b08a8a7a412fa95e1b75bca24f6957f88162f8d1af5bb174ca7f91ef47c0b71')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
24 runhaskell Setup build $MAKEFLAGS
25 runhaskell Setup register --gen-script
26 runhaskell Setup unregister --gen-script
27 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
28 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
34 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
35 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
36 runhaskell Setup copy --destdir="$pkgdir"
37 install -D -m644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.md
38 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE.md