1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=pattern-arrows
5 pkgname=haskell-pattern-arrows
8 pkgdesc="Arrows for Pretty Printing"
9 url="https://blog.functorial.com/posts/2013-10-27-Pretty-Printing-Arrows.html"
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('085d4c2e023a4762af885ec9043ca5b16fae3de4b9ecca879d8a4415d027febeef6b10d705ef0bfbdae1db7346c29269bd60c14a4ca06197d2747748ed3e0070')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
33 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
34 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
35 runhaskell Setup copy --destdir="$pkgdir"
36 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
37 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE