archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-quickcheck-io / trunk / PKGBUILD
blobea73cf9bc449e70bd668af70c6ab36d3d6df420d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=quickcheck-io
4 pkgname=haskell-quickcheck-io
5 pkgver=0.2.0
6 pkgrel=613
7 pkgdesc="Use HUnit assertions as QuickCheck properties"
8 url="https://github.com/hspec/quickcheck-io"
9 license=('MIT')
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-hunit' 'haskell-quickcheck')
12 makedepends=('ghc')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('02e1f40bac8f31f27c21d1d2df9f226816f9da871092b09f0451a8321e250c9e94887f94889be421c9d0034e0a27b02c907d16eb7da5a4376df42c7c1fbd01df')
16 build() {
17     cd $_hkgname-$pkgver
18     
19     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22     runhaskell Setup build $MAKEFLAGS
23     runhaskell Setup register --gen-script
24     runhaskell Setup unregister --gen-script
25     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
29 package() {
30     cd $_hkgname-$pkgver
31     
32     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
33     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
34     runhaskell Setup copy --destdir="$pkgdir"
35     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE