1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-random-fu
7 pkgdesc="Random number generation"
8 url="https://github.com/mokus0/random-fu"
9 license=("custom:PublicDomain")
11 depends=('ghc-libs' 'haskell-erf' 'haskell-math-functions' 'haskell-monad-loops' 'haskell-random'
12 'haskell-random-shuffle' 'haskell-rvar' 'haskell-syb' 'haskell-vector')
14 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
15 sha256sums=('06e6691279e4fcf176d79ad33a4ca6a8d7d831123d64d798f3e5aae4b7c45e40')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
23 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
26 runhaskell Setup build $MAKEFLAGS
27 runhaskell Setup register --gen-script
28 runhaskell Setup unregister --gen-script
29 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
30 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
37 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
38 runhaskell Setup copy --destdir="$pkgdir"