1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=haskell-rank2classes
7 pkgdesc="Standard type constructor class hierarchy, only with methods of rank 2 types"
8 url="https://github.com/blamario/grampa/tree/master/rank2classes"
11 depends=('ghc-libs' 'haskell-data-functor-logistic' 'haskell-distributive')
12 makedepends=('ghc' 'haskell-cabal-doctest' 'haskell-doctest' 'haskell-markdown-unlit'
13 'haskell-tasty' 'haskell-tasty-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('82ec91d86bb60f0e42daa0ca5a7680f5d4be9e91bde257a529c626dc3cda741e4d50f0d15097a061641a1dd524c7eb668650d32158853223747ec89cb7c682e5')
20 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
21 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
22 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
23 runhaskell Setup build $MAKEFLAGS
24 runhaskell Setup register --gen-script
25 runhaskell Setup unregister --gen-script
26 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
27 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 runhaskell Setup test --show-details=direct
38 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
39 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
40 runhaskell Setup copy --destdir="$pkgdir"
41 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
42 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE