archrelease: copy trunk to community-any
[ArchLinux/community.git] / haskell-rate-limit / trunk / PKGBUILD
blob4698c15bf9a6b1bad3bff94c7849fb5b83e0999d
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=rate-limit
4 pkgname=haskell-rate-limit
5 pkgver=1.4.3
6 pkgrel=1
7 pkgdesc="A basic library for rate-limiting IO actions."
8 url="https://github.com/acw/rate-limit"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-time-units')
12 makedepends=('ghc' 'uusi')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('3df92663ef6499326e8f297452a0907b129b253a935ad7b69b253340e1d61376')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' 
30   runhaskell Setup build $MAKEFLAGS
31   runhaskell Setup register --gen-script
32   runhaskell Setup unregister --gen-script
33   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 check() {
38   cd $_hkgname-$pkgver
39   runhaskell Setup test --show-details=direct
42 package() {
43   cd $_hkgname-$pkgver
45   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47   runhaskell Setup copy --destdir="$pkgdir"
48   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
49   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE