1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=recursion-schemes
4 pkgname=haskell-recursion-schemes
7 pkgdesc="Representing common recursion patterns as higher-order functions"
8 url="https://github.com/ekmett/recursion-schemes"
11 depends=('ghc-libs' 'haskell-base-orphans' 'haskell-comonad' 'haskell-data-fix' 'haskell-free'
12 'haskell-th-abstraction')
13 makedepends=('ghc' 'uusi' 'haskell-hunit')
14 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
15 sha512sums=('7e3a585c339d0dea6261129b439e44bfe305a174c1ef92d16cad5d2c2a5d91cf896bfcb654cf69d6a0acc3c0410bcef60d0b85963d9451a8b30dda92ca490512')
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
28 runhaskell Setup build $MAKEFLAGS
29 runhaskell Setup register --gen-script
30 runhaskell Setup unregister --gen-script
31 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
32 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
37 runhaskell Setup test --show-details=direct
43 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
44 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
45 runhaskell Setup copy --destdir="$pkgdir"
46 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
47 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE